• andyc replied to the topic S2 woes in the forum S2 6 years, 3 months ago

    Michael Zeleny;4484 wrote: This is not as reassuring as it might be with a report of remaining Kodak sensor stock at Solms.

    actually I don’t think Leica would ever run out of replacements as under their faulty Sensor replacement policy they would have to replace the whole Camera to the latest S and scrap for parts the faulty one.. err !!……[Read more]

  • Stevie Rave On;4432 wrote: Hi there, I am considering Leica S strongly due to the existence of this lens. I shoot interior so distortion is very important to me as well. Is there any chance you can shoot a grid at the major focal lengths you listed below and post samples or see if you can get it to true rectlinear by the lens correction adjustment…

    [Read more]

  • andyc replied to the topic S2 woes in the forum S2 6 years, 5 months ago

    GMB;4355 wrote: Well, seems it’s my turn. My sensor glass cracked after over2 years in use. And that while on vacation….

    There were several sensors on the earlier S2 that had faulty fittings which pinched the glass covers causing them to crack, usually from or near a corner….you should take it to Leica for checking. They are duty bound…[Read more]

  • Absolutely right Arif, a definite winner for Travel
    very glad you have one as well.
    Andy

  • Hi Tom
    I have not had the chance yet except the first test done on a dull day.. I love the feel of this Lens with smooth zoom, balance and weight.
    The results are superb and with 30mm just 1/2 stop over the fixed one the difference is not noticeable at full 100% on my Mac.
    I used 320 ISO f9.5/180. there is no sign of Moire or colour change.…[Read more]

  • Paratom;4065 wrote: Hi Andy. I had read the Leica info but a) they only say the f-stop at 35, 60 and 90mm, and at 90mm they say f5.0 which seems wrong? because it should be f5.6 at 90mm?

    Hi
    I have just checked and we get the following
    30=3.5
    45=4.3
    60=4.9
    75=5.3
    90=5.6

    this is normal variation pro rata

    hope this is…[Read more]

  • Paratom;4063 wrote: Congrats for the new lens.
    Does the lens extend when one zooms?
    And do you mind to tell the widest f-stop at 35,50 and 70mm?
    Thanks a lot.

    http://s.leica-camera.com/en/DOWNLOADS

    Hi
    this gives all info on lens…

    I have attached photo I took on my iphone showing a credit card size next to it..the front…[Read more]

  • andyc replied to the topic Firmware update 1.0.4.2 in the forum S2 6 years, 7 months ago

    Hi.. I would just like to add that the update also addressed a issue I had reported whereby the top OLED kept defaulting to ‘Medium’ when the S2 was off with a multi Battery Grip attached…I like to keep it brightest in daylight as a quick reference before Shoot.

  • Mark Gowin;4057 wrote: Andy, congratulations on getting the 30-90mm. That lens is at the top of my purchase list. It is a very flexible focal range and has the typical Leica S character – sharp with excellent OOF rendering.

    The little time I spent demoing the lens lead me to the conclusion that the lens hood may not be of much value when the…

    [Read more]

  • andyc replied to the topic H Adaptor S in the forum S2 7 years, 2 months ago

    Example image of H to S Adaptor and HC 300mm
    small jpeg’s unfortunately
    brilliant on DNG’s @ 72Mb

  • andyc replied to the topic H Adaptor S in the forum S2 7 years, 2 months ago

    [COLOR=red]Hi All
    just to let you know that after a visit to Leica Mayfair UK today it was realised that the Adaptor was indeed faulty and the Lens was in perfect working order.. in fact the Lens had only 48 actuations and was the latest one.. wow that was a good one to keep !!
    I was given a new exchange and everything is as it should be…[Read more]

  • andyc replied to the topic H Adaptor S in the forum S2 7 years, 2 months ago

    [I]Hi Fotograzf
    I have checked all contacts and cleaned them..
    I hope to try it on a HD4-50 next week… but,
    the strange thing is, since I have kept the Adaptor on the Lens and only change Lenses with it already attached there seem to be no more problems…. (ooops.. why do I say these things !!)
    There is also a slight Camera ‘click’ on…[Read more]

  • andyc replied to the topic H Adaptor S in the forum S2 7 years, 2 months ago

    Hi Pebbleplace
    Sadly no.. I recently sold my Hasselblad Kit including 5 HC Lenses but no 100/2.2
    I have bought all the non CS Lenses and kept the 300 HC as there is nothing as yet from Leica..
    Don’t forget that Leica are duty bound to honour their pledge to allow you a equivalent CS upgrade with just the difference in price to pay when you…[Read more]

  • andyc replied to the topic H Adaptor S in the forum S2 7 years, 2 months ago

    Hi Josh
    yes I had already updated the firmware beforehand…
    I think it is possibly a rogue Adaptor as it occurs on both my S2 Bodies with or without the Multi Battery Grips attached..
    I had also noticed a hitch when setting the top OLED to brightest with the Grip attached whereby it defaults back to ‘medium’ when the S2 is switched off and…[Read more]

  • Hi Doug

    I was given a demonstration one to try out first and although a bit too expensive I was somewhat impressed with the handling and decided to purchase one.
    I do have very large Hands and find it quite comfortable in use… also with the added Grip Strap attached it is also safer for me to pickup and put down… the vertical format is…[Read more]

  • just had this reply from Germany after finding a bug in the last firmware update that causes the OLED top cover to default to medium brightness with the Multifunction Grip attached

    Dear Mr Cole,
    Thank you very much for your message.

    Please be informed that our technical department was able to reproduce the issue as you…[Read more]

  • just had this reply from Germany 🙂

    Dear Mr Cole,

    Thank you very much for your message.

    Please be informed that our technical department was able to reproduce the issue as you described.

    It seems that this it is really an unreported bug. We thank you very much for your reporting.

    Leica’s…[Read more]

  • Josh Lehrer;2146 wrote: It sounds like you have a bad battery to me. That is a problem I have seen before, where the battery shows that it has some charge remaining but the camera refuses to stay on. At first I thought it was a camera issue but after trying a new battery, I realized it was a defective battery. Send it my way and I will replace…

    [Read more]

  • superb clip that is a very valuable lesson for the faint hearted..
    gives confidence
    thanks David.
    Andy

  • andyc replied to the topic S2 woes in the forum S2 7 years, 6 months ago

    stephan;1816 wrote: same for me here, don’t know why this sensor is so difficult to clean

    Hi Stephan and albireo_double

    The big problem is the Chamber size and if you use a ‘blower’ there is more dust to churn up..I was told that stubborn dust should be removed with the excellent Pentax Orange OCK1 if you can get one and wet Swabs for…[Read more]

  • Load More