• #1148

    I’m probably doing something wrong but can’t seem to get the flash to work with the S2. When I attach the flash, it turns on but doesn’t have an option for TTL-HSS in the mode menu. I tried resetting the flash and camera settings but still nothing. Anyone have any thoughts?


  • #1152


    I saw this same thing last weekend

    It is something really stupid about switching on the camera or the SF58 first … can’t remember which but it is in one of the manuals (in a none obvious place)

    Good luck and will check when I get home this evening


  • #1155
    Josh Lehrer

    I have been playing with this combination a bit today to see what’s what. I tried every combination I could, camera on first, flash on first, camera on then attach flash while off, camera on then attach flash while on. I have yet to find a combination where the flash will not allow me to select TTL-HSS while attached to the camera. If I take the flash off the camera, turn it off, then on again, I lose the ability to choose TTL-HSS, but as soon as I put it back on the camera, I can select TTL-HSS with no difficulty.

  • #1158

    Well I must admit I can’t repeat the phenomenon.

    All OK with me with all lenses tonight.

    AM6 … is it sorted?


  • #1159

    Thanks for looking into it but no good for me. I tried different combos but still not working. I’ll see if I can return this flash and get another one.

  • #1161
    Bobby Lee

    Have you tried selecting different shutter speed?

  • #1163

    Hi Bobby –

    Yes, different speeds, modes. Cleaned the contacts but don’t think the flash and camera are communicating properly.


  • #1170

    I have a different problem with my 58;

    It starts to develop a mind of its own and starts flashing, seemingly randomly. Problem is that unless I have it on my Quantum battery it is discharged when I go make a photo.

    it will happen intermittently and disappear as quickly as it comes on.

    yes, I know it makes “test flashes” from time ot time but this is different, high powered discharges.

    anyone else see this?

You must be logged in to reply to this topic.