• #3033
    Jheroun

    I really want to love the S2, because when its on, it is amazing. But it's letting me down big time. I've resisted using it for assignments anymore because it is so unreliable. First, it started intermittently shooting blanks when tethered, after about 40 captures. White screen, nothing. In between, for no apparent reason, the flash wouldn't fire. Then it would, then it wouldn't. I changed out fresh batteries in the camera and radio transmitter, all the obvious things. Tried the radio slave with other cameras, not a problem.

    So I hadn't used it for awhile until recently street shooting in natural light, untethered with my 70mm. Inexplicably it began to wildly overexpose. First in Auto, then in whatever manual setting I chose. The camera would reset to something crazy setting resulting in a blown out image. Maddeningly, it would revert to normal and then switch back to overexposing so bad there was barely an image recorded. Today, in studio testing new lights, the same problem arose with flash firing now and again for no reason. All this and the camera has hardly been used.

    I've come to the conclusion that I own an expensive doorstop and it must be returned to Leica for an exorcism. Has anyone experienced problems like these?

    Jheroun

  • #3035
    Pete Walentin

    Hi Jheroun,

    I am very sorry to hear that. The only problem I had when shooting tethered was an image which was broken, unreadable. But only one out of two hundred and I had not invested time to find out what the reasons might be.

    Everything else you have experienced is new to me. Maybe an exorcism in Solms will help. I would take care to give Leica CS, if possible at all, reproduction steps which could help to localize the issue, to fix it and most important to verify it before they send the camera back to you.

    Keep us posted.

  • #3036
    Pete Walentin

    What kind of Flash Trigger you are using?

    I am using Profoto Air and had never any issue.

  • #3037
    Jheroun

    Pete Walentin;3361 wrote: Hi Jheroun,

    I am very sorry to hear that. The only problem I had when shooting tethered was an image which was broken, unreadable. But only one out of two hundred and I had not invested time to find out what the reasons might be.

    Everything else you have experienced is new to me. Maybe an exorcism in Solms will help. I would take care to give Leica CS, if possible at all, reproduction steps which could help to localize the issue, to fix it and most important to verify it before they send the camera back to you.

    Keep us posted.

    Good advice. Will do.

  • #3038
    Jheroun

    Pete Walentin;3362 wrote: What kind of Flash Trigger you are using?

    I am using Profoto Air and had never any issue.

    I use a Visatec trigger with Visatec and Broncolor heads. Works like a charm with my two M cameras and Canon 5D MkII.

  • #3039
    Jheroun

    Jheroun;3364 wrote: I use a Visatec trigger with Visatec and Broncolor heads. Works like a charm with my two M cameras and Canon 5D MkII.

    The top panel OLED has also long since ceased to read, so it's a perfect storm of problems. Here comes its European vacation.

  • #3041
    Josh Lehrer

    I've been pleasantly surprised with the S2's reliability over the past few years, however that doesn't mean that problems never happen. Leica's S service in Germany is absolutely fantastic, courteous, and their turnaround times are very quick. If you send the camera directly to them (without going through Leica USA in NJ) it's usually two weeks door-to-door. The faded top OLED is a known issue for some of the earlier cameras, and Leica will replace that for free for the lifetime of the product (as it was a manufacturer's defect). The new OLED is far superior and will not fade. Refer to this post for reference:

    http://www.reddotforum.com/showthread.php/289-OLED-display-going-going

    I think the camera needs a trip to Germany, they'll clean the sensor and viewfinder as well, so it's not a bad idea.

  • #3047
    Jheroun

    Josh Lehrer;3369 wrote: I've been pleasantly surprised with the S2's reliability over the past few years, however that doesn't mean that problems never happen. Leica's S service in Germany is absolutely fantastic, courteous, and their turnaround times are very quick. If you send the camera directly to them (without going through Leica USA in NJ) it's usually two weeks door-to-door. The faded top OLED is a known issue for some of the earlier cameras, and Leica will replace that for free for the lifetime of the product (as it was a manufacturer's defect). The new OLED is far superior and will not fade. Refer to this post for reference:

    http://www.reddotforum.com/showthread.php/289-OLED-display-going-going

    I think the camera needs a trip to Germany, they'll clean the sensor and viewfinder as well, so it's not a bad idea.

    You are so right. And I just read the post on the OLED, very good intel. Curious why you suggest bypassing Leica NJ. I assumed they would be very helpful in shipping, tracking, et al.

  • #3056
    Roger

    Josh advice is what you should do. NJ adds. Weeks to the processdue to shipping and customs.

You must be logged in to reply to this topic.