Discussion Forum Leica M System Leica M (Typ 240) Leica M240 hangs/freezes on startup after updating to 2.1.0 from 2.0.6
  • #27731
    christionk

    Hi, i'm new in leica stuff here.
    I bought a used m240 mint condition on february 2021 and it works flawlessly without any trouble,
    then i updated to 2.1.0 ( full battery and successfull installation ), however it seems like my m240 now hangs / freezes on startup on many occassions.
    i have tried formatting the sd card with sd formatter software, using sandisk 32 95mb/s / 64gb 95mb/s / 64gb 170mb/s without any luck.
    and the camera hangs more often now than before.

    is there any way to downgrade the firmware? i also saw that the firmware page on the leica official website doesnt show leica m240 firmwares again

    have i bricked my camera ?

    and how can i contact leica support ? there's no official leica service centre in my country ( indonesia )

    im sorry for my bad english grammars , and i hope someone can help me with this problem.

  • #27883
    rronaldson

    Have you tried resetting the camera? It's an option in the menu.

You must be logged in to reply to this topic.