Discussion Forum Leica S System S2 Stuck Battery twice.
  • #1648
    andyc

    just wondered if anyone had the same problem as me.
    recently I have had a battery stick in both the S2 Body and Multigrip and both times they had to go back to Germany for repair.. the Body was 38006** while the grip had a completly different Battery and happened a week before when it was attached..
    I also suffered the dreaded cracked Sensor filter on my other S2 38016**
    unlucky or what ??? how can this happen to the mighty S2 ?

  • #1649
    Josh Lehrer

    Andy:

    Sorry to hear that you are having issues. Are you saying that the S2 battery was physically stuck inside both the camera and the grip? That is something I have never seen. What I have seen is batteries that do not lock very well inside the camera, but this appears to be the opposite problem. How did you end up removing the stuck batteries? Or did you need to send the camera to Germany to have them removed and repaired?

    Per your cracked sensor, it is unfortunate but there are still a few S2 bodies out there with sensor cover glass from that bad batch from Kodak…thankfully Leica will always fix these cameras at no charge. Repair usually takes just 2-3 weeks from my experience.

    Hope everything turns out OK, keep us posted!

    Josh

  • #1650
    andyc

    Hi Josh.. yes the batteries were physically stuck inside both the Body and the Grip but at different times.. returned to Solms under warranty.. it was a sudden occurrence both times with a battery change no problem for a few times then just no release with the button in the grip and the switch on the body. I have the Body with Solms just now and request the reason why this should have happened to equipment that would have bought a decent car.. wow Leica what type of QC do you have with the S2 ?
    I will keep you posted with any reply I might get but they would probably be too embarrassed to give me the real truth.. are these parts sent out by demand without proper checks I wonder ?? the grip is Chinese.. hmmm !!! does that tell you anything ?

  • #1652
    Josh Lehrer

    Andy:

    While I cannot be exactly sure why you had this particular problem, I can say from experience that the S2, and most of the cameras I have owned in fact, are very reliable…but there will always be variability. The S2 is a hand built camera, and while Leica's QC is good, they are not perfect. What matters now is how Leica Service handles the situation, and that they deliver your camera back to you in a timely manner.

    Looking forward to a speedy resolution for your concerns!

    Josh

  • #1719
    andyc

    Update
    I now have both S2s back from Solms… each taking 8 days from collection to arrival at my excellent dealers Richard Caplan in St James's London.
    both appear to function correctly but I have been left with a dread of changing the Batteries.. ha! ha!… only a joke… I hope ?
    I was impressed with the priority service awarded to me and even more with my Dealer offering me a brand new set of Trinovid 8×20 as compensation.. now that's the old fashioned service that we have sadly lost over the years and the main reason I will always buy from my Dealer.
    I have tried to update the firmware to the latest v 1.0.2.0 without success.. the instructions state a file size of 7.9 Mb but the download only shows 7.55 Mb. I went through the procedure and the S2 showed the update progress as working. however it took much longer that 60 seconds and when it finished the S2 shut down but the Red function led light would not go out.. I waited about 5 minutes with a totally dead S2 until I decided to remove the Battery and reinsert it. holding my breath the S2 came to life with the old firmware 1.0.1.8 still showing.. phew !!! I don't want to try again unless I have to if I get the Elmarit-S 30. I have the superb 35 which is a bit too close for my liking..
    Any else have this problem ???
    many thanks to all for your comments and advice..
    Andy

  • #1720
    andyc

    Update of Update
    I have succeeded in updating the firmware by reloading everything and removing the multifunction Battery Grip beforehand.
    I do not know if this Grip had anything to do with it or not but all is OK and I look forwards to a Merry Xmas, as I do to all the Members of this Forum.
    good luck in 2012 as well.

  • #1723
    Mark Gowin

    Whew! I am glad you were able to update the firmware. Also, I am very impressed with your dealer taking care of you the way he did.

  • #1724
    Doug

    andyc;1555 wrote: .. the instructions state a file size of 7.9 Mb but the download only shows 7.55 Mb.

    Different operating systems calculate Mb differently. Getting info on the firmware file shows it as 7927512 bytes. Traditionally, a Kb is 1024 bytes and a Mb is 1024 K, so dividing that number by 1024 and then 1024 again should reveal the file is 7.56 Mb.

    Or, these days some computers figure a Kb is 1000 bytes, etc. So, dividing 7927512 bytes by 1000 twice gets you 7.93 Mb. Take your pick. 😎

    Glad you got great service and worked out the firmware update.

You must be logged in to reply to this topic.