• In reply to: David Farkas wrote a new post, Apple Updates MacBook Pro to 8th Gen Processors Finally. For months, Apple users have been expecting a 2018 refresh to the MacBook Pro, last updated in 2016. And today, Apple has addressed at least some of the community's desires for the 13 inch and 15 inch […] View

    Good article David. I ordered mine with the 4TB SSD today. Will report vack

  • Nunnzzzz posted a new activity comment 2 years, 9 months ago

    In reply to: Nunnzzzz posted an update More Issues with S Lenses Well, I just sent my S 180mm lens into Germany last week to fix the same focusing issue that everyone is having. This is my second lens that has had the issue. I woke up this morning to do some shooting and found my S 70mm lens has the SAME ISSUE so needs to be sent in for repair now. This is really crazy and would like to know if everyone is equally frustrated. This system is the most unreliable camera system I have ever experienced and the even more frustration is that Leica refuses to communicate to its loyal customers. In talking with Leica in Germany a few weeks ago I was told a \"fix\" was in the works. If this is this case then why not communicate it. View

    So I am scheduled to have a call with Leica Germany first thing in the morning to discuss the “permanent fix” on my S lenses

  • Nunnzzzz posted a new activity comment 2 years, 9 months ago

    In reply to: Nunnzzzz posted an update
    The Leica S problems continue....so after my 70mm lens didn\'t work i put on the 30-90 zoom and went out to shoot. When I took my first photo i got this. Removed battery and tried everything else and again this is all I got. I assumed my new S007 had now failed but when I got home I put on the 120mm lens and found that all was fine so it seems not only is my 180mm lens into Germany or repair but tomorrow I will be sending in both the 70mm lens and the 30-90mm zooms. Crazy
    View

    so to circle the wagon on the 30-90 zoom. It seems the crazy “color” images I was getting with the 30-90 zoom is a firmware problem with the the 4.0. Thankfully John Kreidler with Leica walked me thru 3-4 software upgrades to finally get the 4.0 to work. It seems they are having issues with this lens when you update the software

  • Nunnzzzz posted a new activity comment 2 years, 9 months ago

    In reply to: David Farkas wrote a new post, Photokina 2016 - Interview with Stephan Schulz, Director of Leica's Professional Business Unit Towards the end of Photokina, I sat down with Stephan Schulz, the global director of Leica's new Business Unit Professional. We talked about what this new professional business unit would mean for customers, […] View

    Did he mention any “fix” for the S Lens focus issues?

  • The Leica S problems continue….so after my 70mm lens didn’t work i put on the 30-90 zoom and went out to shoot. When I took my first photo i got this. Removed battery and tried everything else and again this is all I got. I assumed my new S007 had now failed but when I got home I put on the 120mm lens and found that all was fine so it…

    [Read more]

    • so to circle the wagon on the 30-90 zoom. It seems the crazy “color” images I was getting with the 30-90 zoom is a firmware problem with the the 4.0. Thankfully John Kreidler with Leica walked me thru 3-4 software upgrades to finally get the 4.0 to work. It seems they are having issues with this lens when you update the software

  • More Issues with S Lenses
    Well, I just sent my S 180mm lens into Germany last week to fix the same focusing issue that everyone is having. This is my second lens that has had the issue. I woke up this morning to do some shooting and found my S 70mm lens has the SAME ISSUE so needs to be sent in for repair now. This is really crazy and would…[Read more]

    • So I am scheduled to have a call with Leica Germany first thing in the morning to discuss the “permanent fix” on my S lenses

  • Nunnzzzz posted a new activity comment 2 years, 9 months ago

    In reply to: David Farkas wrote a new post, Photokina 2016 - Day 1: Checking Out the 50mm Summilux-SL ASPH and Multifunction Handgrip This is now my fifth consecutive Photokina, but walking up the steps to South Entrance on opening day still give me a little rush of excitement. What goodies await inside these hallowed walls?Historically, […] View

    jcd – It really does seem as though they are not focused on the S system. Bummer…it was a decent system

  • Tethering – As a follow-up to my “Tethering” issues last week with El Capitan……Josh sent me a new cable and with that new cable everything works perfectly. So if anyone continues to have issues be sure and check the cable.

  • Tethering – As a follow-up to my “Tethering” issues last week with El Capitan……Josh sent me a new cable and with that new cable everything works perfectly. So if anyone continues to have issues be sure and check the cable.

  • In reply to: David Farkas wrote a new post, Leica S (Typ 007) Tethering for Adobe Lightroom and New Image Shuttle v3.2 Now Available After a few iterations of Beta plug-ins from Adobe, we now have full and stable tethering support for the Leica S (Typ 007) in Lightroom. The functionality¬†isn't natively in Lightroom yet, so don't be looking for […] View

    not on a MacBook Pro running El Capitan

  • In reply to: David Farkas wrote a new post, Leica S (Typ 007) Tethering for Adobe Lightroom and New Image Shuttle v3.2 Now Available After a few iterations of Beta plug-ins from Adobe, we now have full and stable tethering support for the Leica S (Typ 007) in Lightroom. The functionality¬†isn't natively in Lightroom yet, so don't be looking for […] View

    not on a MacBook Pro running El Capitan

  • i have downloaded all the new files on the Leica S website and neither the tethering not the Leica Image Shuttle work with a Mac Book Pro running El Capitan

  • i have downloaded all the new files on the Leica S website and neither the tethering not the Leica Image Shuttle work with a Mac Book Pro running El Capitan

  • ok so anyone else STILL having issues with the Leica 7 tethering? mine still says “No Camera Recognized” also the Leica Image Shuttle doesnt work. Frustrating

  • ok so anyone else STILL having issues with the Leica 7 tethering? mine still says “No Camera Recognized” also the Leica Image Shuttle doesnt work. Frustrating

  • In reply to: David Farkas wrote a new post, My photographic adventure through Iceland with the Leica S (Typ 007) In July, I had a unique opportunity to test out the new Leica S (Typ 007). During brainstorming about where to go to try out the new camera, the universe kept pushing me to go to Iceland. So, with some degree of […] View

    great article on the new BEAST

  • New S 007 owner and I absolutely love it. There is a night and day difference between 006 and 007. Has anyone tried using Tethering in LIghtroom. I thought it would be easy. I connect the 007 to my new MacBook Pro via the cord that Leica provided. I go into Lightroom and click on File, Tethered Capture, Start Tethered Capture.…[Read more]

  • Marc – Thank you so much…you perfectly answered my question

  • I have a Leica S (006) and am starting to shoot more indoor portrait type photos. I have a Profoto B-1. When I bought the Profoto I bought the Profoto airplay and it works flawlessly (although not TTL) on the Leica S. I also use the Leica Corded remote. Lately I thought it would be nice to fire the Leica and the Profoto from across the…[Read more]