A password will be e-mailed to you.

Today, Leica has released a firmware update for the full range of current Leica compact digital cameras, including the D-Lux 7, C-Lux and V-Lux 5. The headlining feature of firmware version 2.0 is the improvement in pairing with the Leica FOTOS 2.1 mobile app, also just updated today. The process should now be easier and more stable.

For greater consistency and improved user experience, the same Leica FOTOS menu interface established with the Leica SL2 and Q2 have now been implemented in these cameras with firmware 2.0.

The Leica FOTOS 2.1 update is also a major one, and significant for these cameras. You'll now be able to receive GPS geotagging data for all your photos once you've paired the camera and FOTOS app together.

The app uses the GPS in your phone and takes advantage of the Bluetooth LE (low energy) radio in the camera to maintain an always-on connection without draining your battery. To read more about this and all the other features introduced in FOTOS 2.1, check out our companion article here on Red Dot Forum:

Leica FOTOS App 2.1 Released with New Features


Firmware Files

Each camera has its own firmware. Just click on the appropriate button below to download firmware for your camera. When prompted, make sure to select Save As… and make a note of the saved file location. Usually, this will be in your computer's Downloads folder. Once, downloaded head on down to the instructions to see how to update on your camera.




Instructions for Updating

  1. Copy the firmware file onto a SD Memory Card in its top level folder.
  2. Make sure to turn off the power switch on the camera.
  3. Insert the fully charged battery to the body. If the battery is not fully charged, the update process screen will not appear.
  4. Insert the SD Memory Card into the camera.
  5. Power on camera and press play button. The camera firmware update starts.
  6. The camera will guide you through the backup process.
  7. Wait until this process is finished.
  8. Restart your camera; do not remove the SD card.

15 Responses


    Hi and thanks for your useful article above. I downloaded the firmware update for D-Lux 7.
    Name of the zipped file : DLX7_V20.bin

    Which I cannot open on my Macbook.

    What to do?

    Once this is solved (I hope) can I copy the firmware to my existing SD card with images? On that card I have two folders, one with the images and one named private. Shall I use the private one? Or create a new folder? What is actually meant with “Top Level Folder”? Finally, can I copy the firmware to the SD care when I have the D-Lux connected to my Macbook?


    • David Farkas

      You don’t want to try to open the file on your computer. Simply drag it to an SD card, then insert into your camera. It should not be in any folder.

      • Marc

        I have downloaded this file to my SD card and placed in in the top file “DCIM” and put it back into my camera with a fully charged battery and nothing happens. I pressed play but only get the “No valid picture to play” message. I waited until my lens retracted and still nothing.

      • David Farkas

        The firmware file needs to be placed at the top level (also known as the root directory) of the SD card, not inside the DCIM folder. If it’s inside any folder, the camera can’t see it.

      • JJ

        Do we remove the firmware from the SD card after all is complete and restart?
        thank you.

  2. Ana Vazquez

    Hi! I have a Leica C-Lux, I already have the new software in the root directory of the sim card and still showing “No valid picture to play”. How can I solve this? Thanks for your help!!

  3. Sónia Cunha

    Hi All, I have a C-Lux. So after the update (as instructed) and the restart, can I switch off the camera, remove the SD Card and put a new one? Thank you! Sónia

  4. Sónia Cunha

    Hi Ana, did you already manage your problem? I’m afraid I’ll have the same question… Thank you.

  5. bon

    Hi everyone,

    Pretty sure the .bin file is sitting in the top folder. but I still get “no valid picture to play” when the play button is pressed. Thoughts?

  6. Bruce

    I’ve got the same problem. File is in the root directory, power on the camera and press play and I also get no valid picture to display.

    • Maureen Cox

      Hi Bruce, did you solve the firmware problem in the end? I’ve just bought a used Leica C Lux and I’m having exactly the same problem updating. Have tried everything!
      Many thanks


Leave a Reply

Your email address will not be published.